Sybase Technical Library - Product Manuals Home
[Search Forms] [Previous Section with Hits] [Next Section with Hits] [Clear Search] Expand Search

Part 5  Applications [Table of Contents] Chapter 18   Deploying Your Application

InfoMaker User's Guide

[-] Part 5 Applications
[-] Chapter 17 Working with Applications

Chapter 17
Working with Applications

About this chapter

You can bundle reports, forms, and data pipelines into a package to create a reporting and database-maintenance application. This chapter describes how to create an InfoMaker application.

About applications

When you have completed reports, forms, or data pipelines, you can bundle them in an executable file to create a reporting and database-maintenance application. The reports, forms, and pipelines in an application are usually related by topic, but they need not be. You can bundle any reports, forms, and pipelines you want.

Where you create an application

In InfoMaker, you create applications using a wizard accessed in the Library painter. The wizard prompts you for the reports, forms, and pipelines you want to include and for other aspects of the application such as the icon to be used to represent the application.


No queries
InfoMaker applications do not include queries, which also display in the Library painter.

Identifying an application

Most applications can be identified by selecting Help>About to display information about the application such as the name, name of the company producing the application, version, and so on. After you create an application, you can modify the application's initialization file so your users will see customized information.

For information about identifying your application, see "Identifying your application".

Running an application

You can run the application the same way you run other Windows applications. After you start the application, you can run the reports and forms and pipelines included in the application.

Using pipelines in an application

Having the ability to execute pipelines in an application is particularly useful for mobile users working on laptops that are often not connected to a corporate database. You can pipe a corporate database to the laptop, use forms to update the database, and run reports against the local database. Then you can pipe the local data to the corporate database.

For information about executing a pipeline in an application and modifying the pipeline definition from the application, see "Using a pipeline in an application".

Distributing an application

An application can be for your personal use only, but you can also distribute it to others to use. Users can run your application outside the InfoMaker environment. Having InfoMaker installed is not required.

The requirements for distributing an application with a pipeline differ from the requirements for distributing an application with only forms and reports because pipelines can modify the database by adding and dropping tables.

For information about distributing InfoMaker applications to others, see Chapter 18, "Deploying Your Application".

Creating an application

When you create an application, all the reports, forms, and pipelines you include must be in one library (PBL). In the Library painter, you can move or copy reports, forms, and pipelines from one library to another as needed.

For information about moving or copying objects, see Chapter 2, "Working with Libraries".

What happens

InfoMaker creates two files:

For information about running an application, see "Running an application".

Identifying your application

By default, InfoMaker includes brand information to identify your application when a user displays the Help>About window. But you can make modifications to the application's initialization file to customize the information that identifies your application.

For information, see "Identifying your application".

An application includes a query governor

InfoMaker includes a query governor in an InfoMaker application automatically. The query governor lets you specify the maximum number of rows to be retrieved and the maximum time for retrieval.

For more information, see "Using the query governor in an application".

Reusing an application

When you initiate the creation of an application, InfoMaker checks to see whether an application was previously created using the current library. If so, InfoMaker retains the specifications for the most recent one. You can start fresh or reuse the most recent application.

When you click Yes, the Create Executable dialog box displays with your most recent application's title, filename, and icon. You can modify the entries if you want, and continue to define the application:

raster

Running an application

You can run your application the same way you run other Windows applications. For example, you can double-click the executable file in Explorer or File Manager or you can create an application shortcut on the desktop and double-click the shortcut.

If you create an application shortcut, before you can run your application by double-clicking the shortcut you need to modify the shortcut's Start In property.

What happens when you run an application

When you run the application, the application reads information in the application's initialization file and connects to the database to access the data. Then the application's main window displays with a menu bar and toolbar:

raster

The application toolbar always has an Exit button and optionally has a Reports button, a Pipelines button, and a Forms button. If the application does not have any reports, the toolbar does not have a Reports button (similarly for forms and pipelines). If you defined toolbar buttons for individual reports, forms, or pipelines when you created the application, the toolbar contains these buttons.

Identifying your application

Most applications can be identified by selecting Help>About to display information about the application such as the name, name of the company producing the application, version, and so on. By default, InfoMaker includes the application name and Sybase-brand information to identify your application.

You can modify the application's initialization file so your users will see customized information about you and your company.

Running a report, form, or pipeline

To run a report, form, or pipeline, you can do any of the following:

What happens when you run a report or form

Running a report or form in an executable file is the same as running a report or a form in InfoMaker.


When a report is retrieving data
The number of rows retrieved displays in MicroHelp and the Retrieve button changes to a Cancel button. You can click the Cancel button at any time to stop retrieval.

What happens when you run a pipeline

When you run a pipeline in an application, the Pipeline window displays. You can then execute the pipeline manually or specify delayed execution. Advanced users of the application can redefine a pipeline object if you instruct users how to do this.

For information about executing a pipeline and redefining a pipeline object in the application, see, "Using a pipeline in an application".

For more information

For information about previewing reports, see "Using the Preview view of a report ".

For information about running forms that use built-in InfoMaker form styles, see "Working with forms".

For information about running forms using a style created by a PowerBuilder developer at your organization, see the developer.

Managing the toolbar

You can move the toolbar and suppress the display of text in the toolbar by selecting items from the popup menu.

Managing the open reports, forms, and pipelines

You can manage the display of reports, forms, and pipelines you have opened by selecting items from the Window menu, which InfoMaker automatically provides in the executable.

Using the query governor in an application

When an InfoMaker application (executable file) is created, a query governor is included automatically.

Using a pipeline in an application

When you include a pipeline in an application and run it, the Pipeline window displays. As the window is displaying, messages are written to the Pipeline Log box to indicate connection to the source and destination databases, when these connections are occurring, and the elapsed time:

raster

You can print the log or save the log to any report format. Users may need to send the log to you to use for debugging a pipeline. You can empty the log at any time by clicking the Reset Log button.

Executing pipelines

A pipeline in an application executes when you execute it manually or you set a delayed execution mode to automatically execute the pipeline.

The execution mode (Manual by default) shows in the Execution Mode box. If you set a delayed execution mode, the time settings and a countdown clock display in the When box.

Manual execution

You can manually execute a pipeline anytime, even if you've set a delayed execution mode.

Delayed execution

You can specify delayed automatic execution of the pipeline. This setting remains in effect until you close the Pipeline window.

Delayed/Recurring execution

You can specify delayed and recurring automatic execution of the pipeline. This setting remains in effect until you close the Pipeline window.

If execution errors occur

If execution errors occur, the errors display in the Pipeline Errors box. You can print the errors or save the errors to any report format. You can sometimes correct errors in the Pipeline Errors box.

Users of the application usually should not repair pipeline execution errors. Users should contact you if execution errors occur and send the error log to you for debugging the pipeline. You should usually modify the pipeline object in InfoMaker to fix errors and redeploy the application.

At times, you may want users to fix execution errors by modifying the pipeline definition from the application. Advanced users of the application can modify the application's initialization file to allow them to modify the pipeline object's definition from the application. You can tell users how to do this if needed.

For information about adding a [Pipe] section to the initialization file, see "Modifying the pipeline object's definition".

Repairing execution errors

When a pipeline executes and has execution errors, the error messages display in the Pipeline Errors box in the workspace and instructions for repairing the errors display in a message box:

raster

Modifying the pipeline object's definition

By default, you can execute a pipeline in an application, but you can't modify the pipeline object's definition.

But if you are deploying your application to advanced users, you may want to give users the ability to modify the pipeline object from the application. Allowing users to modify pipelines means that you don't have to modify the pipeline object in InfoMaker, recreate the application, and deploy it immediately. But since the pipeline object definition isn't saved when you modify a pipeline in an application, you should redeploy the application later.

What you can allow users to modify

To modify a pipeline definition, either you or your users must add a new section to the application's initialization file. Users can change the type of pipeline operation and the Commit and Max Errors values. Depending on the quality of the network connection (particularly if users are connecting by telephone from laptops), lowering the Commit and Max Errors values could result in more efficient committing of rows to the database. For example, committing all rows when the database connection is through a 14.4 Kb/sec modem could take a long time and your phone connection could fail. So it may be better to change the Commit value to 10.

Modifying the pipeline definition

After a user's application initialization file has been modified to include the [Pipe] section, the user can use items on the Actions menu to modify the pipeline definition.

For complete information about pipeline types, the Commit value, and the Max Errors value, see Chapter 14, "Working with Data Pipelines ".


Part 5  Applications [Table of Contents] Chapter 18   Deploying Your Application